Upgrade paths

These are valid upgrade paths for Continuous Delivery for Puppet Enterprise (PE).

If you're on version... Upgrade to version... Notes
4.20.0 You're up to date!
4.x (any version in the series) 4.20.0 (current version) You can safely upgrade from any 4.x version to any newer 4.x version.
3.13.8 4.x (any version in the series) You must upgrade to the latest 3.13.x version in order to access the 3.x to 4.x data migration tool, and then you can upgrade past 3.13.x.
3.13.3 or earlier 3.13.8