Supported CIS benchmarks

Comply supports the following CIS operating system benchmarks.

Operating system Supported versions
Alma Linux 8
Amazon Linux 2
CentOS 6, 7
Debian 8, 9, 10
Mac OS X 10.14, 10.15, 11.0, 12
Oracle Linux 6, 7, 8
Red Hat Enterprise Linux (RHEL) 6, 7, 7 STIG, 8
Rocky Linux 8
SUSE Linux Enterprise Server (SLES) 12, 15
Ubuntu 16.04, 18.04, 20.04, 20.04 STIG
Windows 10 Enterprise, 2012, 2012 R2, 2016, 2016 STIG, 2019, 2019 STIG, 2022
Ubuntu users:
  • If you use Ubuntu 16.04, you need Curl with Mutual Transport Layer Security (MTLS) support to upgrade Comply and run scans.
  • The feature for managing Java runtime packages, manage-java, is no longer supported for Ubuntu 16.04 because the Puppet java module is not available in this environment.