Puppet Enterprise 2019.0

These tables show which components are in Puppet Enterprise (PE) releases, covering recent long-term supported (LTS) releases. To see component version tables for a release that has passed its support phase, switch to the docs site for that release.

Puppet Enterprise agent and server components

This table shows the components installed on all agent nodes.
Note: Hiera 5 is a backwards-compatible evolution of Hiera, which is built into Puppet 4.9.0 and higher. To provide some backwards-compatible features, it uses the classic Hiera 3.x.x codebase version listed in this table.
PE Version Puppet Agent Puppet Facter Hiera MCollective RubyOpenSSL
2019.0.1 6.0.4 6.0.4 3.12.13.4.5N/A2.5.11.1.0h
2019.0.06.0.26.0.23.12.03.4.5N/A2.5.11.1.0h
2018.1.5 (LTS)5.5.85.5.83.11.63.4.52.12.42.4.41.0.2n
2018.1.4 5.5.6 5.5.6 3.11.43.4.42.12.32.4.41.0.2n
2018.1.3 5.5.4 5.5.3 3.11.33.4.32.12.22.4.41.0.2n
2018.1.25.5.35.5.23.11.23.4.32.12.22.4.41.0.2n
2018.1.05.5.15.5.13.11.13.4.32.12.12.4.41.0.2n
2017.3.105.3.85.3.73.9.63.4.32.11.52.4.41.0.2n
2017.3.95.3.85.3.73.9.63.4.32.11.52.4.41.0.2n
2017.3.85.3.85.3.73.9.63.4.32.11.52.4.41.0.2n
2017.3.65.3.65.3.63.9.63.4.32.11.52.4.41.0.2n
2017.3.55.3.55.3.53.9.53.4.22.11.42.4.31.0.2n
2017.3.45.3.45.3.43.9.43.4.22.11.42.4.31.0.2n
2017.3.25.3.35.3.33.9.33.4.22.11.42.4.21.0.2k
2017.3.15.3.25.3.23.9.23.4.22.11.32.4.11.0.2k
2017.3.0 5.3.2 5.3.2 3.9.23.4.22.11.32.4.11.0.2k
2016.4.15 (LTS)1.10.144.10.123.6.103.3.32.10.62.1.91.0.2n
2016.4.141.10.144.10.123.6.103.3.32.10.62.1.91.0.2n
2016.4.131.10.144.10.123.6.103.3.32.10.62.1.91.0.2n
2016.4.111.10.124.10.113.6.103.3.32.10.62.1.91.0.2n
2016.4.101.10.104.10.103.6.9­2.10.62.1.91.0.2n
2016.4.9 1.10.94.10.93.6.8­2.10.62.1.91.0.2k
2016.4.8 1.10.84.10.83.6.7­2.10.52.1.91.0.2k
2016.4.7 1.10.54.10.53.6.6­2.10.52.1.91.0.2k
2016.4.6 1.10.44.10.43.6.5­2.10.52.1.91.0.2k
2016.4.5 1.10.14.10.13.6.4­2.10.42.1.91.0.2k
2016.4.31.7.24.7.13.4.23.2.22.9.1 2.1.91.0.2j
2016.4.3 for Ubuntu on i3861.7.14.7.03.4.13.2.12.9.02.1.91.0.2j
2016.4.2 1.7.14.7.03.4.13.2.12.9.02.1.91.0.2j
2016.4.0 1.7.14.7.03.4.13.2.12.9.02.1.91.0.2j
This table shows components installed on server nodes:
PE Version Puppet Server PuppetDB r10k Razor Server Razor Libs PostgreSQL Java ActiveMQ Nginx
2019.0.1 6.0.2 6.0.1 3.0.31.9.3N/A9.6.101.8.0N/A1.14.0
2019.0.06.0.16.0.03.0.21.9.3N/A9.6.101.8.0N/A1.14.0
2018.1.5 (LTS)5.3.65.2.62.6.51.9.2N/A9.6.101.8.05.15.51.14.0
2018.1.4 5.3.5 5.2.4 2.6.21.9.2N/A9.6.101.8.05.15.31.14.0
2018.1.3 5.3.4 5.2.4 2.6.21.9.2N/A9.6.81.8.05.15.31.14.0
2018.1.25.3.35.2.22.6.21.9.2N/A9.6.81.8.05.15.31.12.1
2018.1.05.3.25.2.22.6.21.8.1N/A 9.6.81.8.05.15.31.12.1
2017.3.105.1.65.1.52.6.01.6.03.1.29.6.101.8.05.15.31.14.0
2017.3.95.1.65.1.52.6.01.6.03.1.29.6.81.8.05.15.31.14.0
2017.3.85.1.65.1.52.6.01.6.03.1.29.6.81.8.05.15.31.12.1
2017.3.65.1.65.1.52.6.01.6.03.1.29.6.81.8.05.15.31.12.1
2017.3.55.1.65.1.42.6.01.6.03.1.29.6.61.8.05.14.31.12.1
2017.3.45.1.55.1.42.6.01.6.03.1.29.6.61.8.05.14.31.12.1
2017.3.25.1.45.1.32.5.51.6.03.1.29.6.51.8.05.14.31.12.1
2017.3.15.1.35.1.12.5.51.6.03.1.29.6.51.8.05.14.31.12.1
2017.3.05.1.35.1.12.5.51.6.03.1.29.6.51.8.05.14.31.12.1
2016.4.15 (LTS)2.6.14.2.32.5.51.4.03.1.29.4.191.8.05.15.31.14.0
2016.4.142.6.14.2.32.5.51.4.03.1.29.4.171.8.05.15.31.14.0
2016.4.132.6.14.2.32.5.51.4.03.1.29.4.171.8.05.15.31.12.1
2016.4.112.6.14.2.32.5.51.4.03.1.29.4.171.8.05.15.31.12.1
2016.4.102.6.14.2.32.5.51.4.03.1.29.4.151.8.05.14.31.12.1
2016.4.92.6.04.2.32.5.51.4.03.1.29.4.141.8.05.14.31.12.1
2016.4.82.6.04.2.32.5.51.4.03.1.29.4.141.8.05.14.31.12.1
2016.4.72.6.04.2.32.5.51.4.03.1.29.4.121.8.05.14.31.12.1
2016.4.62.6.04.2.32.5.51.4.03.1.29.4.121.8.05.14.31.8.1
2016.4.52.6.04.2.32.5.41.4.03.1.29.4.91.8.05.14.31.8.1
2016.4.32.6.04.2.32.4.51.4.03.1.29.4.91.8.05.14.31.8.1
2016.4.22.6.04.2.32.4.31.4.03.1.29.4.91.8.05.13.21.8.1
2016.4.02.6.04.2.32.4.31.4.03.1.29.4.91.8.05.13.21.8.1

Master and agent compatibility

Use this table to verify that you're using a compatible version of the  agent for your PE or Puppet master.

Master

PE 3.x

Puppet 3.x

PE 2015.1 through 2017.2

Puppet 4.x

PE 2017.3 through 2018.1

Puppet 5.x

PE 2019.0 and later

Puppet 6.x
Agent3.x
4.x
5.x
6.x
Note:
  • Puppet 3.x has reached end of life and is not actively developed or tested. We retain agent 3.x compabilility with later versions of the master only to enable upgrades.
  • You can use pre-6.x agents with a Puppet 6.x or PE 2019.0 or later master, but this combination doesn't take advantage of the new intermediate certificate authority architecture introduced in Puppet Server 6.0. To adopt the new CA architecture, both your master and agents must be upgraded to 6.x/2019.0, and you must regenerate certificates. If you don't upgrade all of your nodes to 6.x, don't regenerate certificates, because pre-6.x agents won't work with the new CA architecture. 

Back to top