Overview

MCollective Server Allows Installing Arbitrary Packages On Agents

  • Posted May 11, 2017

  • Assessed Risk Level: Medium

  • CVSS: 6.0

Versions of Puppet Enterprise prior to 2016.4.5 or 2017.2.1 shipped with an MCollective configuration that allowed the package plugin to install or remove arbitrary packages on all managed agents. This release adds default configuration to not allow these actions. Customers who rely on this functionality can change this policy.

This vulnerability was found by an internal audit at Puppet.

Status:

Affected Software Versions:

  • Puppet Enterprise prior to 2016.4.5
  • Puppet Enterprise 2016.5.x
  • Puppet Enterprise 2017.1.x

Resolved in:

  • Puppet Enterprise 2016.4.5
  • Puppet Enterprise 2017.2.1