Overview

CVE-2012-3867 (Insufficient input validation)

A bug in Puppet uses insufficient input validation for agent certificate names.

An attacker can trick the administrator into signing an attacker's certificate rather than the intended one by constructing specially crafted certificate requests containing specific ANSI control sequences. It is possible to use the sequences to rewrite the order of text displayed to an administrator such that display of an invalid certificate and valid certificate are transposed. If the administrator signs the attacker's certificate, the attacker can then man-in-the-middle the deployment's agent nodes.

Status

  • Resolved in Puppet 2.6.17 (source), 2.7.18 (source), rpm, deb, dmg, windows
  • Resolved in Puppet Enterprise 1.2.5 and 2.5.2
  • Hotfixes available for Puppet Enterprise 1.0, 1.1, 1.2.x, and 2.0.x

Hotfixes