CVE-2012-1986 Hotfixes

Puppet Enterprise

Version 2.0.x

Debian

  • 2.0/debian/lenny/all/pe-puppet-agent_2.7.9-1puppet6_all.deb
  • 2.0/debian/lenny/all/pe-puppet-common_2.7.9-1puppet6_all.deb
  • 2.0/debian/lenny/all/pe-puppet-master_2.7.9-1puppet6_all.deb
  • 2.0/debian/lenny/pe-puppet_2.7.9-1puppet6.dsc
  • 2.0/debian/lenny/source/pe-puppet_2.7.9-1puppet6.diff.gz
  • 2.0/debian/lenny/source/pe-puppet_2.7.9-1puppet6_amd64.build
  • 2.0/debian/lenny/source/pe-puppet_2.7.9-1puppet6_i386.changes
  • 2.0/debian/lenny/source/pe-puppet_2.7.9.orig.tar.gz
  • 2.0/debian/squeeze/all/pe-puppet-agent_2.7.9-1puppet6_all.deb
  • 2.0/debian/squeeze/all/pe-puppet-common_2.7.9-1puppet6_all.deb
  • 2.0/debian/squeeze/all/pe-puppet-master_2.7.9-1puppet6_all.deb
  • 2.0/debian/squeeze/pe-puppet_2.7.9-1puppet6.dsc
  • 2.0/debian/squeeze/source/pe-puppet_2.7.9-1puppet6.diff.gz
  • 2.0/debian/squeeze/source/pe-puppet_2.7.9-1puppet6_amd64.build
  • 2.0/debian/squeeze/source/pe-puppet_2.7.9-1puppet6_i386.changes
  • 2.0/debian/squeeze/source/pe-puppet_2.7.9.orig.tar.gz
  • Enterprise Linux

  • 2.0/el/4/i386/pe-puppet-2.7.9-4.pe.el4.noarch.rpm
  • 2.0/el/4/i386/pe-puppet-server-2.7.9-4.pe.el4.noarch.rpm
  • 2.0/el/4/SRPMS/pe-puppet-2.7.9-4.pe.el4.src.rpm
  • 2.0/el/4/x86_64/pe-puppet-2.7.9-4.pe.el4.noarch.rpm
  • 2.0/el/4/x86_64/pe-puppet-server-2.7.9-4.pe.el4.noarch.rpm
  • 2.0/el/5/i386/pe-puppet-2.7.9-4.pe.el5.noarch.rpm
  • 2.0/el/5/i386/pe-puppet-server-2.7.9-4.pe.el5.noarch.rpm
  • 2.0/el/5/SRPMS/pe-puppet-2.7.9-4.pe.el5.src.rpm
  • 2.0/el/5/x86_64/pe-puppet-2.7.9-4.pe.el5.noarch.rpm
  • 2.0/el/5/x86_64/pe-puppet-server-2.7.9-4.pe.el5.noarch.rpm
  • 2.0/el/6/i386/pe-puppet-2.7.9-4.pe.el6.noarch.rpm
  • 2.0/el/6/i386/pe-puppet-server-2.7.9-4.pe.el6.noarch.rpm
  • 2.0/el/6/SRPMS/pe-puppet-2.7.9-4.pe.el6.src.rpm
  • 2.0/el/6/x86_64/pe-puppet-2.7.9-4.pe.el6.noarch.rpm
  • 2.0/el/6/x86_64/pe-puppet-server-2.7.9-4.pe.el6.noarch.rpm
  • SLES

  • 2.0/sles/11/i386/pe-puppet-2.7.9-4.pe.noarch.rpm
  • 2.0/sles/11/i386/pe-puppet-server-2.7.9-4.pe.noarch.rpm
  • 2.0/sles/11/SRPMS/pe-puppet-2.7.9-4.pe.src.rpm
  • 2.0/sles/11/x86_64/pe-puppet-2.7.9-4.pe.noarch.rpm
  • 2.0/sles/11/x86_64/pe-puppet-server-2.7.9-4.pe.noarch.rpm
  • Solaris

  • 2.0/solaris/pup-puppet-2.7.9-3.i386.pkg.gz
  • 2.0/solaris/pup-puppet-2.7.9-3.sparc.pkg.gz
  • Ubuntu

  • 2.0/ubuntu/lucid/all/pe-puppet-agent_2.7.9-1puppet6_all.deb
  • 2.0/ubuntu/lucid/all/pe-puppet-common_2.7.9-1puppet6_all.deb
  • 2.0/ubuntu/lucid/all/pe-puppet-master_2.7.9-1puppet6_all.deb
  • 2.0/ubuntu/lucid/pe-puppet_2.7.9-1puppet6.dsc
  • 2.0/ubuntu/lucid/source/pe-puppet_2.7.9-1puppet6.diff.gz
  • 2.0/ubuntu/lucid/source/pe-puppet_2.7.9-1puppet6_amd64.build
  • 2.0/ubuntu/lucid/source/pe-puppet_2.7.9-1puppet6_i386.changes
  • 2.0/ubuntu/lucid/source/pe-puppet_2.7.9.orig.tar.gz
  • Version 1.2.x

    Debian

  • 1.2/debian/lenny/all/pe-puppet-agent_2.6.9-1puppet7_all.deb
  • 1.2/debian/lenny/all/pe-puppet-common_2.6.9-1puppet7_all.deb
  • 1.2/debian/lenny/all/pe-puppet-master_2.6.9-1puppet7_all.deb
  • 1.2/debian/lenny/pe-puppet_2.6.9-1puppet7.dsc
  • 1.2/debian/lenny/source/pe-puppet_2.6.9-1puppet7.diff.gz
  • 1.2/debian/lenny/source/pe-puppet_2.6.9-1puppet7_amd64.build
  • 1.2/debian/lenny/source/pe-puppet_2.6.9-1puppet7_i386.changes
  • 1.2/debian/lenny/source/pe-puppet_2.6.9.orig.tar.gz
  • 1.2/debian/squeeze/all/pe-puppet-agent_2.6.9-1puppet7_all.deb
  • 1.2/debian/squeeze/all/pe-puppet-common_2.6.9-1puppet7_all.deb
  • 1.2/debian/squeeze/all/pe-puppet-master_2.6.9-1puppet7_all.deb
  • 1.2/debian/squeeze/pe-puppet_2.6.9-1puppet7.dsc
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9-1puppet7.diff.gz
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9-1puppet7_amd64.build
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9-1puppet7_i386.changes
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9.orig.tar.gz
  • Enterprise Linux

  • 1.2/el/4/i386/pe-puppet-2.6.9-8.pe.el4.noarch.rpm
  • 1.2/el/4/i386/pe-puppet-server-2.6.9-8.pe.el4.noarch.rpm
  • 1.2/el/4/SRPMS/pe-puppet-2.6.9-8.pe.el4.src.rpm
  • 1.2/el/4/x86_64/pe-puppet-2.6.9-8.pe.el4.noarch.rpm
  • 1.2/el/4/x86_64/pe-puppet-server-2.6.9-8.pe.el4.noarch.rpm
  • 1.2/el/5/i386/pe-puppet-2.6.9-8.pe.el5.noarch.rpm
  • 1.2/el/5/i386/pe-puppet-server-2.6.9-8.pe.el5.noarch.rpm
  • 1.2/el/5/SRPMS/pe-puppet-2.6.9-8.pe.el5.src.rpm
  • 1.2/el/5/x86_64/pe-puppet-2.6.9-8.pe.el5.noarch.rpm
  • 1.2/el/5/x86_64/pe-puppet-server-2.6.9-8.pe.el5.noarch.rpm
  • 1.2/el/6/i386/pe-puppet-2.6.9-8.pe.el6.noarch.rpm
  • 1.2/el/6/i386/pe-puppet-server-2.6.9-8.pe.el6.noarch.rpm
  • 1.2/el/6/SRPMS/pe-puppet-2.6.9-8.pe.el6.src.rpm
  • 1.2/el/6/x86_64/pe-puppet-2.6.9-8.pe.el6.noarch.rpm
  • 1.2/el/6/x86_64/pe-puppet-server-2.6.9-8.pe.el6.noarch.rpm
  • SLES

  • 1.2/sles/11/i386/pe-puppet-2.6.9-8.pe.noarch.rpm
  • 1.2/sles/11/i386/pe-puppet-server-2.6.9-8.pe.noarch.rpm
  • 1.2/sles/11/SRPMS/pe-puppet-2.6.9-8.pe.src.rpm
  • 1.2/sles/11/x86_64/pe-puppet-2.6.9-8.pe.noarch.rpm
  • 1.2/sles/11/x86_64/pe-puppet-server-2.6.9-8.pe.noarch.rpm
  • Solaris

  • 1.2/solaris/pup-puppet-2.6.9-6.i386.pkg.gz
  • 1.2/solaris/pup-puppet-2.6.9-6.sparc.pkg.gz
  • Ubuntu

  • 1.2/ubuntu/lucid/all/pe-puppet-agent_2.6.9-1puppet7_all.deb
  • 1.2/ubuntu/lucid/all/pe-puppet-common_2.6.9-1puppet7_all.deb
  • 1.2/ubuntu/lucid/all/pe-puppet-master_2.6.9-1puppet7_all.deb
  • 1.2/ubuntu/lucid/pe-puppet_2.6.9-1puppet7.dsc
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9-1puppet7.diff.gz
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9-1puppet7_amd64.build
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9-1puppet7_i386.changes
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9.orig.tar.gz
  • Versions 1.0 and 1.1

    Debian

  • 1.1/debian/lenny/all/pe-puppet-agent_2.6.4-1puppet18_all.deb
  • 1.1/debian/lenny/all/pe-puppet-common_2.6.4-1puppet18_all.deb
  • 1.1/debian/lenny/all/pe-puppet-master_2.6.4-1puppet18_all.deb
  • 1.1/debian/lenny/pe-puppet_2.6.4-1puppet18.dsc
  • 1.1/debian/lenny/source/pe-puppet_2.6.4-1puppet18.diff.gz
  • 1.1/debian/lenny/source/pe-puppet_2.6.4-1puppet18_amd64.build
  • 1.1/debian/lenny/source/pe-puppet_2.6.4-1puppet18_i386.changes
  • 1.1/debian/lenny/source/pe-puppet_2.6.4.orig.tar.gz
  • Enterprise Linux

  • 1.1/el/4/i386/pe-puppet-2.6.4-13.pe.el4.noarch.rpm
  • 1.1/el/4/i386/pe-puppet-server-2.6.4-13.pe.el4.noarch.rpm
  • 1.1/el/4/SRPMS/pe-puppet-2.6.4-13.pe.el4.src.rpm
  • 1.1/el/4/x86_64/pe-puppet-2.6.4-13.pe.el4.noarch.rpm
  • 1.1/el/4/x86_64/pe-puppet-server-2.6.4-13.pe.el4.noarch.rpm
  • 1.1/el/5/i386/pe-puppet-2.6.4-13.pe.el5.noarch.rpm
  • 1.1/el/5/i386/pe-puppet-server-2.6.4-13.pe.el5.noarch.rpm
  • 1.1/el/5/SRPMS/pe-puppet-2.6.4-13.pe.el5.src.rpm
  • 1.1/el/5/x86_64/pe-puppet-2.6.4-13.pe.el5.noarch.rpm
  • 1.1/el/5/x86_64/pe-puppet-server-2.6.4-13.pe.el5.noarch.rpm
  • 1.1/el/6/i386/pe-puppet-2.6.4-13.pe.el6.noarch.rpm
  • 1.1/el/6/i386/pe-puppet-server-2.6.4-13.pe.el6.noarch.rpm
  • 1.1/el/6/SRPMS/pe-puppet-2.6.4-13.pe.el6.src.rpm
  • 1.1/el/6/x86_64/pe-puppet-2.6.4-13.pe.el6.noarch.rpm
  • 1.1/el/6/x86_64/pe-puppet-server-2.6.4-13.pe.el6.noarch.rpm
  • SLES

  • 1.1/sles/11/i386/pe-puppet-2.6.4-15.pe.noarch.rpm
  • 1.1/sles/11/i386/pe-puppet-server-2.6.4-15.pe.noarch.rpm
  • 1.1/sles/11/SRPMS/pe-puppet-2.6.4-15.pe.src.rpm
  • 1.1/sles/11/x86_64/pe-puppet-2.6.4-15.pe.noarch.rpm
  • 1.1/sles/11/x86_64/pe-puppet-server-2.6.4-15.pe.noarch.rpm
  • Solaris

  • 1.1/solaris/pup-puppet-2.6.4-6.i386.pkg.gz
  • 1.1/solaris/pup-puppet-2.6.4-6.sparc.pkg.gz
  • Ubuntu

  • 1.1/ubuntu/lucid/all/pe-puppet-agent_2.6.4-1puppet18_all.deb
  • 1.1/ubuntu/lucid/all/pe-puppet-common_2.6.4-1puppet18_all.deb
  • 1.1/ubuntu/lucid/all/pe-puppet-master_2.6.4-1puppet18_all.deb
  • 1.1/ubuntu/lucid/pe-puppet_2.6.4-1puppet18.dsc
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4-1puppet18.diff.gz
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4-1puppet18_amd64.build
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4-1puppet18_i386.changes
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4.orig.tar.gz
  • Puppet

  • Puppet 2.6.15 (tar.gz)
  • Puppet 2.7.13 (tar.gz)
  • We also have made Puppet 2.7.13 and 2.6.15 RPMs available on yum.puppetlabs.com

    We have Puppet 2.7.13 DEBs available at apt.puppetlabs.com.

    Puppet has been updated on rubygems.org as well.

    Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.