CVE-2011-3872 Hotfixes

Puppet Enterprise

Version 1.2.x

Debian

  • 1.2/debian/lenny/all/pe-puppet-agent_2.6.9-1puppet4_all.deb
  • 1.2/debian/lenny/all/pe-puppet-common_2.6.9-1puppet4_all.deb
  • 1.2/debian/lenny/all/pe-puppet-master_2.6.9-1puppet4_all.deb
  • 1.2/debian/lenny/pe-puppet_2.6.9-1puppet4_amd64.changes
  • 1.2/debian/lenny/source/pe-puppet_2.6.9-1puppet4.diff.gz
  • 1.2/debian/lenny/source/pe-puppet_2.6.9-1puppet4.dsc
  • 1.2/debian/lenny/source/pe-puppet_2.6.9.orig.tar.gz
  • 1.2/debian/squeeze/all/pe-puppet-agent_2.6.9-1puppet4_all.deb
  • 1.2/debian/squeeze/all/pe-puppet-common_2.6.9-1puppet4_all.deb
  • 1.2/debian/squeeze/all/pe-puppet-master_2.6.9-1puppet4_all.deb
  • 1.2/debian/squeeze/pe-puppet_2.6.9-1puppet4_amd64.changes
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9-1puppet4.diff.gz
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9-1puppet4.dsc
  • 1.2/debian/squeeze/source/pe-puppet_2.6.9.orig.tar.gz
  • Enterprise Linux

  • 1.2/el/4/i386/pe-puppet-2.6.9-6.pe.noarch.rpm
  • 1.2/el/4/i386/pe-puppet-server-2.6.9-6.pe.noarch.rpm
  • 1.2/el/4/SRPMS/pe-puppet-2.6.9-6.pe.src.rpm
  • 1.2/el/5/i386/pe-puppet-2.6.9-6.pe.el5.noarch.rpm
  • 1.2/el/5/i386/pe-puppet-server-2.6.9-6.pe.el5.noarch.rpm
  • 1.2/el/5/SRPMS/pe-puppet-2.6.9-6.pe.el5.src.rpm
  • 1.2/el/6/i386/pe-puppet-2.6.9-6.pe.el6.noarch.rpm
  • 1.2/el/6/i386/pe-puppet-server-2.6.9-6.pe.el6.noarch.rpm
  • 1.2/el/6/SRPMS/pe-puppet-2.6.9-6.pe.el6.src.rpm
  • SLES

  • 1.2/sles/11/i386/pe-puppet-2.6.9-6.pe.noarch.rpm
  • 1.2/sles/11/i386/pe-puppet-server-2.6.9-6.pe.noarch.rpm
  • 1.2/sles/11/SRPMS/pe-puppet-2.6.9-6.pe.src.rpm
  • Solaris

  • 1.2/solaris/i386/pup-puppet-2.6.9-4.i386.pkg
  • 1.2/solaris/i386/pup-puppet-2.6.9-4.i386.pkg.gz
  • 1.2/solaris/sparc/pup-puppet-2.6.9-4.sparc.pkg
  • 1.2/solaris/sparc/pup-puppet-2.6.9-4.sparc.pkg.gz
  • Ubuntu

  • 1.2/ubuntu/lucid/all/pe-puppet-agent_2.6.9-1puppet4_all.deb
  • 1.2/ubuntu/lucid/all/pe-puppet-common_2.6.9-1puppet4_all.deb
  • 1.2/ubuntu/lucid/all/pe-puppet-master_2.6.9-1puppet4_all.deb
  • 1.2/ubuntu/lucid/pe-puppet_2.6.9-1puppet4_amd64.changes
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9-1puppet4.diff.gz
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9-1puppet4.dsc
  • 1.2/ubuntu/lucid/source/pe-puppet_2.6.9.orig.tar.gz
  • Versions 1.0 and 1.1

    Debian

  • 1.1/debian/lenny/all/pe-puppet-agent_2.6.4-1puppet16_all.deb
  • 1.1/debian/lenny/all/pe-puppet-common_2.6.4-1puppet16_all.deb
  • 1.1/debian/lenny/all/pe-puppet-master_2.6.4-1puppet16_all.deb
  • 1.1/debian/lenny/pe-puppet_2.6.4-1puppet16_amd64.changes
  • 1.1/debian/lenny/source/pe-puppet_2.6.4-1puppet16.diff.gz
  • 1.1/debian/lenny/source/pe-puppet_2.6.4-1puppet16.dsc
  • 1.1/debian/lenny/source/pe-puppet_2.6.4.orig.tar.gz
  • Enterprise Linux

  • 1.1/el/4/i386/pe-puppet-2.6.4-11.pe.noarch.rpm
  • 1.1/el/4/i386/pe-puppet-server-2.6.4-11.pe.noarch.rpm
  • 1.1/el/4/SRPMS/pe-puppet-2.6.4-11.pe.src.rpm
  • 1.1/el/5/i386/pe-puppet-2.6.4-11.pe.el5.noarch.rpm
  • 1.1/el/5/i386/pe-puppet-server-2.6.4-11.pe.el5.noarch.rpm
  • 1.1/el/5/SRPMS/pe-puppet-2.6.4-11.pe.el5.src.rpm
  • 1.1/el/6/i386/pe-puppet-2.6.4-11.pe.el6.noarch.rpm
  • 1.1/el/6/i386/pe-puppet-server-2.6.4-11.pe.el6.noarch.rpm
  • 1.1/el/6/SRPMS/pe-puppet-2.6.4-11.pe.el6.src.rpm
  • SLES

  • 1.1/sles/11/i386/pe-puppet-2.6.4-13.pe.noarch.rpm
  • 1.1/sles/11/i386/pe-puppet-server-2.6.4-13.pe.noarch.rpm
  • 1.1/sles/11/SRPMS/pe-puppet-2.6.4-13.pe.src.rpm
  • Solaris

  • 1.1/solaris/i386/pup-puppet-2.6.4-4.i386.pkg
  • 1.1/solaris/i386/pup-puppet-2.6.4-4.i386.pkg.gz
  • 1.1/solaris/sparc/pup-puppet-2.6.4-4.sparc.pkg
  • 1.1/solaris/sparc/pup-puppet-2.6.4-4.sparc.pkg.gz
  • Ubuntu

  • 1.1/ubuntu/lucid/all/pe-puppet-agent_2.6.4-1puppet15_all.deb
  • 1.1/ubuntu/lucid/all/pe-puppet-common_2.6.4-1puppet15_all.deb
  • 1.1/ubuntu/lucid/all/pe-puppet-master_2.6.4-1puppet15_all.deb
  • 1.1/ubuntu/lucid/pe-puppet_2.6.4-1puppet15_amd64.changes
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4-1puppet15.diff.gz
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4-1puppet15.dsc
  • 1.1/ubuntu/lucid/source/pe-puppet_2.6.4.orig.tar.gz
  • Puppet

  • Puppet 2.6.12 (tar.gz)
  • Puppet 2.7.6 (tar.gz)
  • We also have made Puppet 2.7.6 and 2.6.12 RPMs available on yum.puppetlabs.com.

    Puppet 2.7.6 is available on apt.puppetlabs.com.

    Puppet has been updated on rubygems.org as well.

    Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.