CVE-2022-0675 - Puppet Firewall Module

  • Posted 2022-02-28

  • Assessed Risk Level: Medium

  • CVSS 3.1 Base Score: 5.6

In certain situations it is possible for an unmanaged rule to exist on the target system that has the same comment as the rule specified in the manifest. This could allow for unmanaged rules to exist on the target system and leave the system in an unsafe state.

Status:

Affected software versions:

  • Puppet Firewall Module prior to 3.3.0

Resolved in:

  • Puppet Firewall Module 3.4.0