Overview

CVE-2018-6513 - Unprivileged User Can Execute Arbitrary Code in Windows

  • Posted June 7, 2018

  • Assessed Risk Level: High

  • CVSS 3 Base Score: 8.8

Previous versions of Puppet Enterprise 2016.4, 2017.3, and 2018.1 were vulnerable to an attack where an unprivileged user on Windows agents could write custom facts that can escalate privileges on the next puppet run. This was possible through the loading of shared libraries from untrusted paths.

Status:

Affected software versions:

  • Puppet Enterprise 2016.4.x prior to 2016.4.12
  • Puppet Enterprise 2017.3.x prior to 2017.3.7
  • Puppet Enterprise 2018.1.x prior to 2018.1.1
  • Puppet Agent 1.10.x prior to 1.10.13
  • Puppet Agent 5.3.x prior to 5.3.7
  • Puppet Agent 5.5.x prior to 5.5.2

Resolved in:

  • Puppet Enterprise 2016.4.12
  • Puppet Enterprise 2017.3.7
  • Puppet Enterprise 2018.1.1
  • Puppet Agent 1.10.13
  • Puppet Agent 5.3.7
  • Puppet Agent 5.5.2