CVE-2018-6512 - Pre-install Vulnerability in Razor-Server

  • Posted June 7, 2018

  • Assessed Risk Level: Medium

  • CVSS 3 Base Score: 6.1

The previous version of Puppet Enterprise 2018.1 is vulnerable to unsafe code execution when upgrading pe-razor-server.


Affected software versions:

  • Puppet Enterprise 2018.1.x prior to 2018.1.1
  • razor-server and pe-razor-server prior to

Resolved in:

  • Puppet Enterprise 2018.1.1
  • razor-server and pe-razor-server
Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.