Compatibility with Puppet agent

We've updated our documentation to remove harmful terminology.
Sections

Puppet Server 7 is compatible with Puppet agents version 4 and above.

In Platform 7, Puppet Server removed support for the old Puppet 3 HTTP APIs. This means that Puppet 3 agents cannot be used with primary servers running Puppet Server 7.

It also removed the ability to opt in to using the legacy auth.conf file. All endpoint access must now be controlled with the HOCON auth.conf file. See the auth.conf docs for details.

How helpful was this page?

If you leave us your email, we may contact you regarding your feedback. For more information on how Puppet uses your personal information, see our privacy policy.

Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.