System requirements

This release was removed from general availability due to upgrade issues.
Docs for the latest available release are here.
This version is out of date. For current versions, see Puppet Enterprise support lifecycle.
Sections

system requirements depend on your deployment type and size. Before installing, ensure your systems are compatible with infrastructure and agent requirements.

Note: primary servers must run on some variant of . You can't run primary servers on .
Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.