Puppet Enterprise 2017.3

These are the known issues for Razor in this release.

NEW: Razor upgrade to PE 2017.3 fails

An issue with the PostgreSQL upgrade in PE 2017.3 causes upgrade of Razor server nodes to fail. The failure results in an error message similar to this:
Notice: /Stage[main]/Pe_install::Upgrade::Postgres/Exec[migrate to new postgres]/returns: Failure, exiting
As a workaround, after receiving this error message, on the Razor server node as root, run:
puppet resource service pe-razor-server ensure=stopped
puppet resource service pe-postgresql ensure=stopped
yum install -y pe-postgresql
rm -rf /opt/puppetlabs/server/data/postgresql/9.6
su -s /bin/bash pe-postgres -c "/opt/puppetlabs/server/bin/initdb --encoding '' --pgdata '/opt/puppetlabs/server/data/postgresql/9.6/data'"
su -s /bin/bash pe-postgres -c "/opt/puppetlabs/server/apps/postgresql/bin/pg_upgrade -b /opt/puppetlabs/server/apps/postgresql/9.4/bin -B /opt/puppetlabs/server/apps/postgresql/bin -d /opt/puppetlabs/server/data/postgresql/9.4/data -D /opt/puppetlabs/server/data/postgresql/9.6/data"
puppet agent -t

NEW: Razor can't be installed or upgraded to 2017.3 on a node whose OS differs from the master

Due to a bug in the pe_razor module, you can't install or upgrade the Razor server on a node whose operating system is different from the master.

As a workaround, on your master, manually download the tarball that corresponds to your Razor server node and unpack the package's platform directory over the corresponding directory in /opt/puppetlabs/server/data/packages/public/current.

For example, from the root of an unpacked PE Enterprise Linux 7 tarball, run:
rm -rf /opt/puppetlabs/server/data/packages/public/current/el-7-x86_64/* 
cp -r packages/el-7-x86_64/* /opt/puppetlabs/server/data/packages/public/current/el-7-x86_64
On the Razor server node, run yum clean expire-cache to be sure that the new package is available. You can then upgrade the agent and run Puppet as normal.

Temp files aren't removed in a timely manner

Temp files used by Razor might not be removed as quickly as expected. Files are eventually removed when the object is finalized.

Updates might be required for VMware ESXi 5.5 igb files

You might have to update your VMware ESXi 5.5 ISO with updated igb drivers before you can install ESXi with Razor. See the VMwaredriver package download page for updated igb drivers.

Razor commands resulted in JSON warning

When you run Razor commands, you might get this warning: MultiJson is using the default adapter (ok_json). We recommend loading a different JSON library to improve performance.

You can disregard the warning. However, if you're using Ruby 1.8.7, you can install a separate JSON library, such as json_pure, to prevent the warning from appearing.

pe-razor doesn't allow java_args configuration

Most PE services enable you to configure java_args in the console, but Razor requires you to hard code them in the init script.

Back to top