System requirements

Sections

Refer to these system requirements for your Continuous Delivery for Puppet Enterprise (PE) installation.

Supported Puppet Enterprise versions

The following versions of Puppet Enterprise (PE) are supported for use with Continuous Delivery for PE.

PE version
2018.1.x
2017.3.x

Supported browsers

The following browsers are supported for use with the Continuous Delivery for PE web UI.

BrowserSupported versions
Google ChromeCurrent version as of release
Mozilla FirefoxCurrent version as of release
Microsoft EdgeCurrent version as of release
Apple Safari Current version as of release
See an issue? Please file a JIRA ticket in our [DOCUMENTATION] project
Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.