System requirements

Sections

Refer to these system requirements for your Puppet Comply installation.

Hardware and port requirements

The Comply server must meet the following minimum requirements:
Memory Storage CPUs
16 GB
  • At least 40 GB for /var/lib/containerd
  • At least 200 GB for /opt/replicated.

  • At least 50 GB for /var/lib/kubelet

  • At least 3 GB for /var/lib/etcd
12 (or equivalent)

Open port requirements

Comply is deployed on a Kubernetes cluster, which requires the following ports:
Port Protocol Purpose Source Destination
PE ports
8143 TCP PE integration Comply PE Orchestrator
8081 TCP PE integration Comply PuppetDB
4433 TCP PE integration Comply PE RBAC
Comply ports
443 TCP Comply access User browser Comply UI
443 TCP Sending reports Scan target node Comply server
Platform ports
30900 TCP Prometheus Administrator workstation Kubernetes host
30902 TCP Grafana Kubernetes host Kubernetes host
30903 TCP Alertmanager Kubernetes host Kubernetes host
6443 TCP Kubernetes API Administrator workstation Kubernetes host
6783 TCP/UDP Kubernetes networking weave Kubernetes host Kubernetes host
6784 TCP Kubernetes networking weave Kubernetes host Kubernetes host
8800 TCP Platform admin console Platform admin console Kubernetes host
10250 TCP Platform admin console Kubernetes host Kubernetes host

Supported operating systems

Comply can be installed on these operating systems:
Operating system Supported versions
Ubuntu 16.04 (kernel version >= 4.15), 18.04 (recommended).
CentOS

7.4, 7.5, 7.6, 7.7, 7.8, 8.1, 8.2 (CentOS 8.x requires containerd)

Red Hat Enterprise Linux (RHEL)

7.4, 7.5, 7.6, 7.7, 7.8, 7.9, 8.1, 8.2 (RHEL 8.x requires containerd)

Amazon Linux 2

Supported benchmarks

Comply supports the following CIS operating system benchmarks:

Operating system Supported versions
Amazon Linux 2
CentOS

6, 7, 8

Debian 8, 9, 10
Oracle Linux 6, 7, 8
Red Hat Enterprise Linux (RHEL) 6, 7, 8
SUSE Linux Enterprise Server (SLES) 12, 15
Ubuntu 16.04, 18.04, 20.04
Windows 2012 R2, 2016, 2019

Supported Puppet Enterprise versions

The following versions of Puppet Enterprise (PE) are supported for use with Comply:
PE version
2019.8.4 and later

For more on PE versions, see Puppet Enterprise support lifecycle.

Target node requirements

As part of the Comply configuration process, PE installs the CIS assessor on the nodes you classify for scans. The assessor requires Java 1.8 or higher. If Java is not present or has the wrong version on the target node, PE installs or upgrades Java. Java 1.8 requires the node to have at least 2 GB of free RAM.

Supported browsers

The following browsers are supported for use with the Comply user interface:

Browser Supported versions
Google Chrome Current version as of release
Mozilla Firefox

Current version as of release

Microsoft Edge Current version as of release
Apple Safari Current version as of release
How helpful was this page?

If you leave us your email, we may contact you regarding your feedback. For more information on how Puppet uses your personal information, see our privacy policy.

Puppet sites use proprietary and third-party cookies. By using our sites, you agree to our cookie policy.